Strange Issue with Slowdown

Home Forums Bug Reports and Questions Strange Issue with Slowdown

This topic contains 4 replies, has 2 voices, and was last updated by  GoldwaterDLS 4 months, 1 week ago.

Viewing 5 posts - 1 through 5 (of 5 total)
  • Author
    Posts
  • #786

    MegaTheGamer
    Participant

    I downloaded Rock Force recently after seeing an LP of it, as I wanted to play the game for myself and maybe stream it sometime down the line. Unfortunately, I’m now having the most inexplicable problem I’ve ever experienced, which I’ll try to describe in as much detail as I can. I booted up the game for the first time today, and there were no issues right off. I watched the opening play out, fiddled with some settings, restarted it to make sure the setting changes took, and played the intro stage with no problems. I idled on the stage select for a while as I responded to Skype messages, maybe ten minutes. I started Spark Man’s stage and suddenly noticed his intro was playing out very slowly. The sound was fine, in fact, it ran ahead of the game while it slowly introduced Spark Man to me. Concerned, I exited the game and felt over toward my cooling fan. Once assured that my computer was not heating up (it wasn’t even warm), I closed out everything else and booted the game again. This time, even the intro was playing excessively slowly, despite running fine less than an hour prior. Nothing has changed on my computer at this point. After confirming the intro stage was now also slowing down greatly, I went into the settings to see if upping the game’s priority would help. That screen was responding just fine, but the pan to the right when going into the specific menus was also slow. At this point, I went through the settings, changing things around and even restoring all the defaults, resetting each time to make sure they were taking effect. Nothing even did anything to alleviate to problem, much less fix it. As a last resort, I completely purged the game form my system and redownloaded it. The issue still persisted even then. I have no idea what the issue is.

    A couple possible explanations:
    -I’m using Windows 10. No idea if this would be an issue.
    -While working in the settings, I tried to use a controller through Xinput. When that didn’t work, I closed the program. Reopening it later did not help the game.

    That’s all I can come up with. Sorry I can’t explain what the issue is, there’s not much to tell. Any ideas are appreciated.

    #787

    GoldwaterDLS
    Keymaster

    I’ve had reports of slow down before, and I think the problem stems from the sound extension I used for GameMaker. Sadly, there isn’t really a way to fix it immediately. I’m probably going to have to make a version of the game that uses a different sound extension, like FMOD, for the computers that seem to have this issue.

    Out of curiosity, have you played any other Game Maker made Mega Man games like Super Danny 2, Mega Man: Dr. Wily’s Final Attack, or Super Fighting Robot to see if they suffer from the same problem? If they do, then it might be an issue with older versions of Game Maker, and there really isn’t anything I can do about that.

    #788

    MegaTheGamer
    Participant

    I haven’t played any other Mega Man GM games, no. I played AM2R on the same, and I think that was Game Maker? I could try Super Fighting Robot if it would help narrow things down. I’ve since also tried running it in Conpatibility Mode for Win7 and Win8, to no avail.

    I doubt it’s Game Maker itself though, since the game ran at full speed right at first, and then slowed down after. I’m no creator, though, so you would know better than me.

    #799

    MegaTheGamer
    Participant

    An update to this: once I had some time, I went in and really fiddled around with lots of compatibility settings and ran a number of troubleshooters on the game. The good news is, I’ve fixed the slowdown entirely! The not-so-good news? I’m still not sure what the problem was in the first place or why what I did fixed it.

    I haven’t tested it under a long play session yet, but here’s the settings I’m able to run it at full speed under:
    -Running in Compatibility Mode for Windows XP (Service Pack 3)
    -Allowing display scaling on high DPI settings
    -And I’m running the program as an admin, which may be overriding a conflict with/false positive from Norton?

    Those are the big changes I can narrow it down to, though I doubt the second one is doing much. I’m also not sure if this is just a workaround to some issue with running the game on a newer OS, since I still don’t know what the actual source of the problem was. Regardless, perhaps this will work for other users as well, or help identify the root cause?

    #800

    GoldwaterDLS
    Keymaster

    Thanks for updating me on this. I currently have Windows 8.1 and, even for me, my game ran at its smoothest on my old Windows XP computer; I wouldn’t be surprised if changing the Compatibility Mode had something to do with it.

    Anyway, I’m glad you got it to work.

Viewing 5 posts - 1 through 5 (of 5 total)

You must be logged in to reply to this topic.